CT-ink Audio Forum

 Forgot password?
 Register
View: 170|Reply: 5

Definitive Tech BP2004TL - Sub Issue

[Copy link]

1

Threads

3

Posts

9

Credits

Novice

Rank: 1

Credits
9
Post time 2017-6-28 12:28:00 | Show all posts |Read mode
I have a surround system with 2 - BP2004TL and a CLR2500 and 4 - BPX that I have not used because I moved and left them with my brother.  I recently picked them up and hooked up the 2 BP2004TL's and it appears one of them have an issue with the subwoofer not working (light goes, but subwoofer is not working).  I know these are pretty old (2005ish), is it going to be worth/possible trying to have it fixed?
Thanks
               
Reply

Use magic Report

26

Threads

745

Posts

1568

Credits

Gold member

Rank: 6Rank: 6

Credits
1568
Post time 2017-6-28 12:33:00 | Show all posts

                       
                       
        Quote:
       
                       
                               
                                        Originally Posted by toshiba5
                                       
                                I have a surround system with 2 - BP2004TL and a CLR2500 and 4 - BPX that I have not used because I moved and left them with my brother.  I recently picked them up and hooked up the 2 BP2004TL's and it appears one of them have an issue with the subwoofer not working (light goes, but subwoofer is not working).  I know these are pretty old (2005ish), is it going to be worth/possible trying to have it fixed?
Thanks
                       
               
Fuse?
Try a different wall socket using an extension cord.
               
Reply Support Not support

Use magic Report

1

Threads

3

Posts

9

Credits

Novice

Rank: 1

Credits
9
 Author| Post time 2017-6-28 12:53:00 | Show all posts

                       
                       
        Quote:
       
                       
                               
                                        Originally Posted by gajCA
                                       
                                Fuse?
Try a different wall socket using an extension cord.
                       
               
I thought so at first because the light was out.  Swapped the fuse and still has an issue (although now the light goes on).
               
Reply Support Not support

Use magic Report

11

Threads

112

Posts

277

Credits

Full Member

Rank: 3Rank: 3

Credits
277
Post time 2017-6-28 12:54:00 | Show all posts

                       
                       
        Quote:
       
                       
                               
                                        Originally Posted by toshiba5
                                       
                                I thought so at first because the light was out.  Swapped the fuse and still has an issue (although now the light goes on).
                       
               
I would contact Definitive and see what they say. They have great customer service. They'll be able to walk you though things to find the issue.
Sent from my Pixel using Tapatalk
               
Reply Support Not support

Use magic Report

1

Threads

3

Posts

9

Credits

Novice

Rank: 1

Credits
9
 Author| Post time 2017-6-28 13:01:00 | Show all posts

                       
                       
        Quote:
       
                       
                               
                                        Originally Posted by Hetfieldjames
                                       
                                I would contact Definitive and see what they say. They have great customer service. They'll be able to walk you though things to find the issue.
Sent from my Pixel using Tapatalk
                       
               
Thanks for the tip - I will give them a call
               
Reply Support Not support

Use magic Report

11

Threads

112

Posts

277

Credits

Full Member

Rank: 3Rank: 3

Credits
277
Post time 2017-6-28 13:03:00 | Show all posts

                       
                        No problem. I'm curious to see what they say myself.
Sent from my Pixel using Tapatalk
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile version|Dark room|CT-ink Inc.  

2017-10-18 21:10 GMT+8 , Processed in 0.176047 second(s), 22 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

Quick Reply To Top Return to the list